Eg.
boolean isCurrent = false;
你怎么命名它的getter和setter?
Eg.
boolean isCurrent = false;
你怎么命名它的getter和setter?
当前回答
Setter: public void setCurrent(boolean val)
Getter: public boolean getCurrent()
对于布尔值,也可以使用
public boolean isCurrent()
其他回答
我相信会是:
void setCurrent(boolean current)
boolean isCurrent()
private boolean current;
public void setCurrent(boolean current){
this.current=current;
}
public boolean hasCurrent(){
return this.current;
}
数据类型Boolean的setter/getter方法和类中的Boolean(对于pojo/实体)之间有一个可标记的点。
对于Boolean和Boolean, setter方法都应该是setXXX(),而getter方法分别是getXXX()和isXXX()
例子:
(a)如果属性定义为布尔值
private Boolean active;
setter/getter方法
public Boolean getCheck() { // getXXX()
return check;
}
public void setCheck(Boolean check) {
this.check = check;
}
(b)如果属性定义为布尔值
private boolean check;
setter/getter方法
public boolean isCheck() { // isXXX()
return check;
}
public void setCheck(boolean check) {
this.check = check;
}
Setter: public void setCurrent(boolean val)
Getter: public boolean getCurrent()
对于布尔值,也可以使用
public boolean isCurrent()
http://geosoft.no/development/javastyle.html#Specific
is prefix should be used for boolean variables and methods. isSet, isVisible, isFinished, isFound, isOpen This is the naming convention for boolean methods and variables used by Sun for the Java core packages. Using the is prefix solves a common problem of choosing bad boolean names like status or flag. isStatus or isFlag simply doesn't fit, and the programmer is forced to chose more meaningful names. Setter methods for boolean variables must have set prefix as in: void setFound(boolean isFound); There are a few alternatives to the is prefix that fits better in some situations. These are has, can and should prefixes: boolean hasLicense(); boolean canEvaluate(); boolean shouldAbort = false;